ros-fuerte-openni-kinect on Ubuntu 12.04

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ros-fuerte-openni-kinect on Ubuntu 12.04

adigoil
This post was updated on .
Hi,

I am facing a problem trying to get openni_kinect working on my Ubuntu 12.04 and ros fuerte. We were previously working on Ubuntu 11.10  and ros electric and openni_kinect for ros electric worked seamlessly. We are looking at possible upgrade options but openni_kinect is giving some problems. Sorry for being so verbose but I will list out the problems I am having.

The ros_fuerte_openni_kinect built without problems, but when I do "roslaunch openni_launch openni.launch" i get the following errors:

1) Both roscore and roslaunch give this error :
           
         Exception AttributeError: Attribute("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored.

I get a bunch of these for almost all the nodes.

SOLUTION TRIED : http://bugs.python.org/issue14308 though they mention that the bug has been fixed, but it did not work for me.


2) The next error is seen in "roswtf"

    The following packages have rpath issues in manifest.xml:
* openni_launch: found "-L/opt/ros/fuerte/lib", but no matching "-Wl, -rpath, /opt/ros/fuerte/lib"
and I get this for each and every package that openni_launch includes.

SOLUTION TRIED : http://answers.ros.org/question/10246/what-is-the-correct-usage-of-rpath-in-manifestxml/ I followed this fix but roswtf still gives me the same errors, im not sure why.


3) rviz shows some PointCloud Data but the only topics I can subscribe to are camera/depth_registered and camera/depth..! But I am concerned about the roswtf errors and python errors


Any help or direction would deeply be appreciated.

Thanks!

Loading...