[Ros-kinect] openni_camera.openni_node.launch won't start

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Ros-kinect] openni_camera.openni_node.launch won't start

futureignobel
Hi,

I've installed Diamondback variant mobile from source a couple of days ago. Then I added image_transport, vision_opencv, perception_pcl_addons and ni. Everything compiled fine. After building openni_camera I tried to run roslaunch openni_camera openni_node.launch, but unfortunately the kinect node got killed everytime I tried this as I also documented here, as I thought this might be related: http://answers.ros.org/question/269/openni_nodelaunch-warning-recursive-print#521 .

Then I saw there is also a openni_kinect stack which includes openni_camera, so I downloaded and compiled this one instead of ni (and deleted ni). Unfortunately the whole thing is still not working, but the output is slightly different:
process[openni_node1-2]: started with pid [3221]
process[kinect_base_link-3]: started with pid [3226]
process[kinect_base_link1-4]: started with pid [3227]
process[kinect_base_link2-5]: started with pid [3236]
process[kinect_base_link3-6]: started with pid [3247]
[ INFO] [1299682836.033725620]: [/openni_node1] Number devices connected: 1
[ INFO] [1299682836.034331843]: [/openni_node1] 1. device on bus 001:31 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00364814366047A'
[ INFO] [1299682836.038946398]: [/openni_node1] searching for device with index = 1
[openni_node1-2] process has died [pid 3221, exit code -4].
log files: /home/user/.ros/log/fc4411f6-4a5d-11e0-bde6-001d7e94a572/openni_node1-2*.log
The log is saying:
[roscpp_internal] [2011-03-09 16:00:35,930] [thread 0xb696a740]: [DEBUG] UDPROS server listening on port [55561]
[roscpp_internal] [2011-03-09 16:00:35,940] [thread 0xb696a740]: [DEBUG] Started node [/openni_node1], pid [3221], bound on [user-desktop], xmlrpc port [50421], tcpros port [47638], logging to [/home/user/.ros/log/fc4411f6-4a5d-11e0-bde6-001d7e94a572/openni_node1-2.log], using [real] time
[roscpp_internal] [2011-03-09 16:00:35,961] [thread 0xb696a740]: [DEBUG] XML-RPC call [getParam] returned an error (-1): [Parameter [/openni_node1/num_worker_threads] is not set]
[ros.openni_camera./openni_node1] [2011-03-09 16:00:36,033] [thread 0xb696a740]: [INFO] [/openni_node1] Number devices connected: 1
[ros.openni_camera./openni_node1] [2011-03-09 16:00:36,034] [thread 0xb696a740]: [INFO] [/openni_node1] 1. device on bus 001:31 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00364814366047A'
[ros.openni_camera./openni_node1] [2011-03-09 16:00:36,038] [thread 0xb696a740]: [INFO] [/openni_node1] searching for device with index = 1
[roscpp_internal] [2011-03-09 16:00:36,160] [thread 0xb6969b70]: [DEBUG] Accepted connection on socket [7], new socket [16]
[roscpp_internal] [2011-03-09 16:00:36,160] [thread 0xb6969b70]: [DEBUG] TCPROS received a connection from [192.168.5.101:46329]
[roscpp_internal] [2011-03-09 16:00:36,160] [thread 0xb6969b70]: [DEBUG] Connection: Creating TransportSubscriberLink for topic [/rosout] connected to [callerid=[/rosout] address=[TCPROS connection to [192.168.5.101:46329 on socket 16]]]
My udev rules are set as said in Wiki:
ATTRS{idProduct}=="0200",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0300",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0400",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0500",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0600",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="02ae",ATTRS{idVendor}=="045e",MODE="666",GROUP="video"
ATTRS{idProduct}=="02ad",ATTRS{idVendor}=="045e",MODE="666",GROUP="video"
ATTRS{idProduct}=="02b0",ATTRS{idVendor}=="045e",MODE="666",GROUP="video"
Any clues? I'd be really grateful for any help as I run out of ideas already. Before I reinstalled ROS a couple of days ago everything run smoothly. I posted this one here as well, so please answer there if you can: http://answers.ros.org/question/326/openni_cameraopenni_nodelaunch-wont-start .

Regards,
Tom


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect