[Ros-kinect] issues with the kinect connection

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Ros-kinect] issues with the kinect connection

Favio Saponara
Hi list

I have a problem with the connection with the kinect.
I had success installing the openni driver available in Ros.
http://www.ros.org/wiki/openni_camera

then I needed to install the software from openni.org. after I installed it I cannot more use my kinect because it is not being recognized by my computer.

If I launch roslaunch openni_camera openni_node.launch
i got this:

----------------------------------
... logging to /home/favio/.ros/log/b5fc7666-6975-11e0-8fe9-d8a25e947136/roslaunch-favio-laptop-1830.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://favio-laptop:49951/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [1844]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to b5fc7666-6975-11e0-8fe9-d8a25e947136
process[rosout-1]: started with pid [1857]
started core service [/rosout]
process[openni_node1-2]: started with pid [1860]
process[kinect_base_link-3]: started with pid [1861]
process[kinect_base_link1-4]: started with pid [1862]
process[kinect_base_link2-5]: started with pid [1863]
process[kinect_base_link3-6]: started with pid [1864]
[ INFO] [1303101519.013758123]: [/openni_node1] No devices connected.... waiting for devices to be connected

--------------------------------------




Instead if I tried to use the binaries inside the Openi/Platform/Linux/Bin/Release folder I get this message:
------------------
One or more of the following nodes could not be enumerated:


Press any key to continue . . .

----------------



I've tried to delete all the files and to reinstall again but now I get the same result :(

Any ideas?
Thanks,

Favio


--
http://www.youtube.com/faviuz


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] issues with the kinect connection

Favio Saponara
HI again,

trying to solve this problem I went forward but now I get new errors (and I don't know if this is better and worst).

I installed freenect and with that driver che connection it's working.

then I moved to the OpenNi driver inside Avin2.

https://github.com/avin2/SensorKinect

installing this and running the binaries of the OpenNi folder I get the connection working.


Finally I tried again the
roslaunch openni_camera openni_node.launch

command
I get this new error:

-------------------------------
could it be caused by a conflict with the avin and/ freenect drivers?
SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [6634]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to bfa55758-699f-11e0-8662-d8a25e947136
process[rosout-1]: started with pid [6647]
started core service [/rosout]
process[openni_node1-2]: started with pid [6659]
process[kinect_base_link-3]: started with pid [6660]
process[kinect_base_link1-4]: started with pid [6661]
process[kinect_base_link2-5]: started with pid [6662]
process[kinect_base_link3-6]: started with pid [6663]
terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  unsigned int openni_wrapper::OpenNIDriver::updateDeviceList() @ /tmp/buildd/ros-diamondback-openni-kinect-0.1.3/debian/ros-diamondback-openni-kinect/opt/ros/diamondback/stacks/openni_kinect/openni_camera/src/openni_driver.cpp @ 114 : number of streams and devices does not match: 1 devices, 2 depth streams, 2 image streams
[openni_node1-2] process has died [pid 6659, exit code -6].
log files: /home/favio/.ros/log/bfa55758-699f-11e0-8662-d8a25e947136/openni_node1-2*.log

-----------------------------


thanks,

Favio


On Mon, Apr 18, 2011 at 8:58 AM, Favio Saponara <[hidden email]> wrote:
Hi list

I have a problem with the connection with the kinect.
I had success installing the openni driver available in Ros.
http://www.ros.org/wiki/openni_camera

then I needed to install the software from openni.org. after I installed it I cannot more use my kinect because it is not being recognized by my computer.

If I launch roslaunch openni_camera openni_node.launch
i got this:

----------------------------------
... logging to /home/favio/.ros/log/b5fc7666-6975-11e0-8fe9-d8a25e947136/roslaunch-favio-laptop-1830.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://favio-laptop:49951/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [1844]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to b5fc7666-6975-11e0-8fe9-d8a25e947136
process[rosout-1]: started with pid [1857]
started core service [/rosout]
process[openni_node1-2]: started with pid [1860]
process[kinect_base_link-3]: started with pid [1861]
process[kinect_base_link1-4]: started with pid [1862]
process[kinect_base_link2-5]: started with pid [1863]
process[kinect_base_link3-6]: started with pid [1864]
[ INFO] [1303101519.013758123]: [/openni_node1] No devices connected.... waiting for devices to be connected

--------------------------------------




Instead if I tried to use the binaries inside the Openi/Platform/Linux/Bin/Release folder I get this message:
------------------
One or more of the following nodes could not be enumerated:


Press any key to continue . . .

----------------



I've tried to delete all the files and to reinstall again but now I get the same result :(

Any ideas?
Thanks,

Favio


--
http://www.youtube.com/faviuz




--
http://www.youtube.com/faviuz


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] issues with the kinect connection

Suat Gedikli
In reply to this post by Favio Saponara
The official OpenNI driver does not support MS Kinects. So please use the debians provided by ROS. See http://www.ros.org/wiki/openni_kinect for more details. Also Avins driver does not support the uncompressed Bayer image for Kinects.

-Suat
Suat
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] issues with the kinect connection

Hordur Johannsson
Hi Suat

Where can I find the source that is used for the openni-dev and
ps-engine ubuntu packages?

Thanks,
Hordur

On Mon, 2011-04-18 at 16:34 -0700, Suat Gedikli wrote:

> The official OpenNI driver does not support MS Kinects. So please use the
> debians provided by ROS. See http://www.ros.org/wiki/openni_kinect for more
> details. Also Avins driver does not support the uncompressed Bayer image for
> Kinects.
>
> -Suat
>
> -----
> Suat
> --
> View this message in context: http://kinect-with-ros.976505.n3.nabble.com/Ros-kinect-issues-with-the-kinect-connection-tp2833314p2836830.html
> Sent from the Kinect with ROS mailing list archive at Nabble.com.
> _______________________________________________
> Ros-kinect mailing list
> [hidden email]
> https://code.ros.org/mailman/listinfo/ros-kinect


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] issues with the kinect connection

Suat Gedikli
Hi,

the code is here:

-Suat

On Tue, Apr 19, 2011 at 9:18 AM, Hordur Johannsson <[hidden email]> wrote:
Hi Suat

Where can I find the source that is used for the openni-dev and
ps-engine ubuntu packages?

Thanks,
Hordur

On Mon, 2011-04-18 at 16:34 -0700, Suat Gedikli wrote:
> The official OpenNI driver does not support MS Kinects. So please use the
> debians provided by ROS. See http://www.ros.org/wiki/openni_kinect for more
> details. Also Avins driver does not support the uncompressed Bayer image for
> Kinects.
>
> -Suat
>
> -----
> Suat
> --
> View this message in context: http://kinect-with-ros.976505.n3.nabble.com/Ros-kinect-issues-with-the-kinect-connection-tp2833314p2836830.html
> Sent from the Kinect with ROS mailing list archive at Nabble.com.
> _______________________________________________
> Ros-kinect mailing list
> [hidden email]
> https://code.ros.org/mailman/listinfo/ros-kinect


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect
Suat
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] issues with the kinect connection

Ali Abbas
I had tried out to get code from here. then I had used the make command to build it. During this process system has checked out new code and halted (i mean no further improvement in checking out the code. All other processes on this system are going well). Trace can be found in the attachments. Kindly guide me.

On Wed, Apr 20, 2011 at 12:57 AM, Suat Gedikli <[hidden email]> wrote:
Hi,

the code is here:

-Suat


On Tue, Apr 19, 2011 at 9:18 AM, Hordur Johannsson <[hidden email]> wrote:
Hi Suat

Where can I find the source that is used for the openni-dev and
ps-engine ubuntu packages?

Thanks,
Hordur

On Mon, 2011-04-18 at 16:34 -0700, Suat Gedikli wrote:
> The official OpenNI driver does not support MS Kinects. So please use the
> debians provided by ROS. See http://www.ros.org/wiki/openni_kinect for more
> details. Also Avins driver does not support the uncompressed Bayer image for
> Kinects.
>
> -Suat
>
> -----
> Suat
> --
> View this message in context: http://kinect-with-ros.976505.n3.nabble.com/Ros-kinect-issues-with-the-kinect-connection-tp2833314p2836830.html
> Sent from the Kinect with ROS mailing list archive at Nabble.com.
> _______________________________________________
> Ros-kinect mailing list
> [hidden email]
> https://code.ros.org/mailman/listinfo/ros-kinect


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect




--
Regards,
Ali Abbas


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect

code check out traces.txt (53K) Download Attachment
Loading...