Re: [Ros-kinect] [PCL-users] Unresolved symbols in pcl_io, Natty

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] [PCL-users] Unresolved symbols in pcl_io, Natty

Jochen Sprickerhof
* divya <[hidden email]> [2011-09-08 20:48]:
> Hi

Hi divya,

first of all, this is the wrong mailing list, let's move it to
[hidden email].

> I have taken the latest pcl library and am still getting this error! Please
> suggest !
>
>
> divya@Nova:~/openni_kinect/openni_kinect/openni_tracker$ rosrun
> openni_tracker openni_tracker
>
> /home/divya/openni_kinect/openni_kinect/openni_tracker/bin/openni_tracker:
> symbol lookup error:
> /home/divya/openni_kinect/openni_kinect/openni_tracker/bin/openni_tracker:
> undefined symbol: xnContextAddRef
>
> Divya
>


* divya <[hidden email]> [2011-09-08 23:15]:

> Hi Trunky ,
>
> divya@Nova:~$ dpkg -l openni-dev ps-engine
> Desired=Unknown/Install/Remove/Purge/Hold
> |
> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name           Version        Description
> +++-==============-==============-============================================
> rc  openni-dev     1.3.2.1-4+natt OpenNI Framework - libraries
> rc  ps-engine      5.0.3.3-3+natt ps-engine for OpenNI Framework - libraries

these are the versions in the PCL PPA, if you want to use ROS, please
use the packages for openni_kinect and everything from over here:
http://www.ros.org/wiki/electric/Installation/Ubuntu (assuming you are
on Ubuntu)?

> I have uninstalled the whole pack as of now . can you please tell me the
> correct steps to follow while installation using rosinstall. I followed
> ..http://www.ros.org/wiki/openni_kinect but the make install fails due to
> @sed not found at some time during installation.

could you please paste the error?

> I wanted to run and play with the packages openni_tracker and openni_camera.
>
> The unstable version is running fine but i dont have those packages in it. I
> uninstalled it before proceeding to stable versions

Which versions did you use exactly and where did you get them?

Cheers,

Jochen
_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect
Loading...