Kinect Connectiviy Problem (Openni_kinect)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Kinect Connectiviy Problem (Openni_kinect)

Ali Abbas
Dear All

I am using Ubuntu 10.10 and diamondback release of ROS. I installed these on laptop Dell Latitude D610. Using Openni_kinect stack. I followed instructions from the following link;

http://www.ros.org/wiki/openni_camera

But no success. then I tried to run the launch file using the debugger. I added following instruction in launch file at line 5 to activate the debugger;

launch-prefix="gdb -ex run --args"

Attached is the traces and launch file. Please guide me in this regard. Thanks in advance

Regards,
Ali Abbas

ErrorDesc
openni_node01.launch
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] Kinect Connectiviy Problem (Openni_kinect)

Eric Perko
Ali,

Could you try a source-based installation as described here: http://www.ros.org/wiki/openni_kinect

I believe the openni debs are built with optimizations turned on such as sse2/sse3 , so you may have to make some modifications to their launch files if the CPU in your laptop doesn't support sse3 (which would cause the Illegal instruction trap you had in your backtrace). There is an answer on answers.ros.org that could point you in the right direction for making the required modifications: http://answers.ros.org/question/341/how-to-compile-openni_ros-with-sse2-only-support

- Eric

On Mon, May 30, 2011 at 8:01 AM, Ali Abbas <[hidden email]> wrote:
Dear All

I am using Ubuntu 10.10 and diamondback release of ROS. I installed these on
laptop Dell Latitude D610. Using Openni_kinect stack. I followed
instructions from the following link;

http://www.ros.org/wiki/openni_camera

But no success. then I tried to run the launch file using the debugger. I
added following instruction in launch file at line 5 to activate the
debugger;

launch-prefix="gdb -ex run --args"

Attached is the traces and launch file. Please guide me in this regard.
Thanks in advance

Regards,
Ali Abbas

http://kinect-with-ros.976505.n3.nabble.com/file/n3001703/ErrorDesc
ErrorDesc
http://kinect-with-ros.976505.n3.nabble.com/file/n3001703/openni_node01.launch
openni_node01.launch

--
View this message in context: http://kinect-with-ros.976505.n3.nabble.com/Kinect-Connectiviy-Problem-Openni-kinect-tp3001703p3001703.html
Sent from the Kinect with ROS mailing list archive at Nabble.com.
_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect


_______________________________________________
Ros-kinect mailing list
[hidden email]
https://code.ros.org/mailman/listinfo/ros-kinect
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ros-kinect] Kinect Connectiviy Problem (Openni_kinect)

Ali Abbas
Hello Eric,

Thanks for assistance things are working.


Regards,
Ali
Loading...