A few questions on ROS Mit Kinect Demo

classic Classic list List threaded Threaded
1 message Options
owh
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

A few questions on ROS Mit Kinect Demo

owh
I have been learning ubuntu+ros+kinect for a few weeks and been trying to get the MIT Kinect demos to work in my setup: Ubuntu 11.10 x64, ROS-Electric.  I have a Bilibot.

So far I managed to run the hand, finger detection and robot follower after various fixes.  However, the following problems remain stubborn:

1.  mapping_rviz_plugin

I am unable to visualise the fingers and skeleton in rviz due to "Plugin from package [mapping_rviz_plugin] not loaded for display class" error.  I tried "rosmake mapping_rviz_plugin", tried re-"rosmake rviz", tried re-started system without success.  I do not know what else to try.  Has anyone solved the problem apart from the normally suggested "rosmake mapping_rviz_plugin".

2.  fatal error: SFML/Audio.hpp: NO such file or directory

I received "fatal error: SFML/Audio.hpp: NO such file or directory" when "rosmake piano".  I tried "rosdep install piano" and it complained "Unable to locate package libsfml-audio 1.5".  I tried edit the rosdep.yaml in piano and kinect_utils folder to change to libsfml-audio1.6, however rosdep keeps saying:

Executing script below with cwd=/tmp
{{{
#!/bin/bash
#Packages ['libsfml-audio1.5', 'libsfml-dev']
sudo apt-get install libsfml-audio1.5 libsfml-dev
}}}

Does anyone know where do rosdep obtain the above info. It doesn't seem to refer to the rosdep.yaml in the package/stack folder. I checked the mainfest.xml and only refer to libsfml as rosdep.

I tried manually "sudo apt-get install libsfml-audio1.6" as this is the version for Ubuntu 11.10.  The apt installed without problem. However, "rosmake piano" continues to give the error: "fatal error: SFML/Audio.hpp: No such file or directory".

3.  latest openni

All the Kinect demos I tried on ROS required me to surrender (calibration pose) to the robot.  I am aware that latest Openni api does not require this step.  I have not been able to find information to work with latest Openni api in ROS.  Does anyone know if this is available or I shall just wait?

I have posted questions at answers.ros.org however there was no reply.  Hopeful to get help here.  Thanks a lot.



Loading...